visopsys.org
http://visopsys.org/forums/

install-*.sh problems
http://visopsys.org/forums/viewtopic.php?f=3&t=163
Page 1 of 2

Author:  osmiumusa [ Sun Dec 18, 2011 5:31 pm ]
Post subject:  install-*.sh problems

Hello again.

Man, it seems like I have no luck with these install scripts again... but this time I'm using CentOS! ;)

The problem happens in install.sh, called from install-floppy.sh, called from install-cd.sh. I did some debugging and found that the problem was comming from "mount" in the install.sh. It says "mount: you must specify the filesystem type". What should I put into the filesystem argument, if anything, or should I modify something else? This didn't happen in 0.7 so maybe this is just a release bug?

Thank you :)

~osmiumusa

Author:  andymc [ Sun Dec 18, 2011 7:31 pm ]
Post subject:  Re: install-*.sh problems

Hi mate,

Are you logged in as root?

Andy

Author:  osmiumusa [ Sun Dec 18, 2011 8:49 pm ]
Post subject:  Re: install-*.sh problems

Yes, I am root (that is a powerful statement :) ). For some reason I had to chmod all of these files so that they had the "x" attribute so I could execute them. I don't think that has anything to do with it, but that may be a useful tidbit of info.

Author:  andymc [ Sun Dec 18, 2011 11:31 pm ]
Post subject:  Re: install-*.sh problems

That is confusing. That script is used to create the boot floppy image inside the CD-ROM .iso image. The only mount command in the image-floppy.sh script specifies the filesystem type as msdos (-t msdos)...

The only time I've seen errors like that is when I launched it as non-root, so it gave a permission error when attempting to mount something that wasn't listed in the /etc/fstab file.

Author:  osmiumusa [ Tue Dec 20, 2011 1:50 pm ]
Post subject:  Re: install-*.sh problems

There is another mount command in the Unix installation script that doesn't appear to specify what filesystem to use. What should I tell it?

Author:  osmiumusa [ Sun Jan 15, 2012 5:54 pm ]
Post subject:  Re: install-*.sh problems

Ok, I fixed it. But just out of curiosity, what changed between this version's ISO and 0.7's? They look different in MagicISO (running on Windows 7) 0.7 has all capital names by default (probably due to the fs used) but 0.71 does not... also, is the kernel name supposed to have 3 spaces at the end of it?

Here's a suggestion... in the change log, make a note of the files that were changed/added/deleted. It would help kernel developers, like me, migrate between versions. :)

Thanks,

osmiumusa :mrgreen:

Author:  andymc [ Mon Jan 16, 2012 1:40 am ]
Post subject:  Re: install-*.sh problems

Ahh good, glad you figured it out. Hmm, the ISOs shouldn't be notably different aside from the coding changes. Are you sure that one of your tools hasn't "Windows-ized", or corrupted your 0.7 ISO? I always generate them on Linux, and I don't think anything really changed in my environment between the 2 versions.

The 3 spaces you're seeing at the end of the kernel name are consistent with the other strange 'DOS-like' stuff you described. In FAT (short filename mode), files with no extension have 3 spaces in the second part of their 8.3-format file names.

Strange though.

Andy

Author:  osmiumusa [ Tue Jan 17, 2012 3:16 am ]
Post subject:  Re: install-*.sh problems

The reason I ask is because I tried to change the name of the kernel. And it keeps saying its not in the root directory. Here's what I did:

a) Changed the output of ./src/kernel/Makefile
b) Changed loaderLoadKernel.s variable to reflect it
c) Changed install-files.basic

Am I missing something?

osmiumusa

Author:  andymc [ Tue Jan 17, 2012 10:26 am ]
Post subject:  Re: install-*.sh problems

Why would you want to change the name of the kernel? :naughty: ;)

Sounds like your filesystem got corrupted, frankly.

Author:  osmiumusa [ Tue Jan 17, 2012 4:05 pm ]
Post subject:  Re: install-*.sh problems

No no don't get the wrong idea... its more of a self challenge thing. I'm a freshman in high-school and I do kinda want the challenge of many things.

I think you may be right. i'll keep the name (honestly there is no reason to change it, I would have reverted it)

osmiumusa

Page 1 of 2 All times are UTC
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/