visopsys.org

Visopsys Forums
It is currently Mon Dec 18, 2017 8:17 am

All times are UTC




Post new topic Reply to topic  [ 8 posts ] 
Author Message
 Post subject: Visopsys 0.81 Released
PostPosted: Fri Jun 09, 2017 11:20 pm 
Offline
User avatar

Joined: Tue Nov 16, 2010 7:20 pm
Posts: 460
Hello everybody,

I've had a bit less free time lately, while my new daughter grew through her newborn phase, but I've been steadily polishing the last big 0.8 release in late-night coding sessions, as well as working on new features for the next big release. There were quite a lot of changes accumulating, so I decided it was time to package things up and do a release, available now on the download page http://visopsys.org/download

The change log http://visopsys.org/download/change-log has the details, but here's the executive summary:

Code:
Overview: This maintenance version polishes the 0.8 release with bug fixes, enhanced hardware support, mouse scroll-wheel integration, better EXT4 filesystem handling, and improved reliability and performance.


I know some of you had experienced problems with certain hardware since the introduction of the APIC driver; I can't promise that I've fixed everything, but I think things are in a better state now.


Top
 Profile  
 
 Post subject: Re: Visopsys 0.81 Released
PostPosted: Wed Jun 14, 2017 8:08 pm 
Offline
User avatar

Joined: Tue May 20, 2014 5:19 pm
Posts: 80
Hello Andy. I understand about the little one. I had four of them myself soooo many years ago.

Anyway - relative to the new version of Visopsys (.81): horray! horray!

The .81 version of Visopsys now works on my Athlon 7860 dual core x86_64, which is on an ASUS N68 motherboard. It has 2G memory and is from the 2012 timeframe (approximately). Version 8.0pre was working except for just the mouse. Now the wireless USB (Logitech) mouse is working fine!

Also glad to hear you're putting a TCP stack into version .90.

- Ron


Top
 Profile  
 
 Post subject: Re: Visopsys 0.81 Released
PostPosted: Wed Jun 14, 2017 9:17 pm 
Offline
User avatar

Joined: Tue Nov 16, 2010 7:20 pm
Posts: 460
Hi Ron, thanks! Nice to see you again :-)

Glad to hear things are working better for you. My new-ish workstation is similar to yours, except maybe a couple of years newer - 8-core, Athlon64, Asus or Asrock (something like that) motherboard, and Nvidia. It's got several USB (1+2+3) controllers and dual I/O APICs. The OS wasn't working on it (usually I'm using it to develop, not to test!) but I decided to focus on getting it working, and solved a few problems along the way.

Does the scroll wheel on your wireless USB mouse work? You can test it in e.g. a command window or the tree in the devices program. That's the one thing that I couldn't figure out on this workstation. Mine's a Microsoft wireless mouse with a composite keyboard/mouse receiver dongle thingy.

Andy


Top
 Profile  
 
 Post subject: Re: Visopsys 0.81 Released
PostPosted: Thu Jun 15, 2017 2:40 pm 
Offline
User avatar

Joined: Tue May 20, 2014 5:19 pm
Posts: 80
andymc wrote:
Hi Ron, thanks! Nice to see you again :-)

Glad to hear things are working better for you. My new-ish workstation is similar to yours, except maybe a couple of years newer - 8-core, Athlon64, Asus or Asrock (something like that) motherboard, and Nvidia. It's got several USB (1+2+3) controllers and dual I/O APICs. The OS wasn't working on it (usually I'm using it to develop, not to test!) but I decided to focus on getting it working, and solved a few problems along the way.

Does the scroll wheel on your wireless USB mouse work? You can test it in e.g. a command window or the tree in the devices program. That's the one thing that I couldn't figure out on this workstation. Mine's a Microsoft wireless mouse with a composite keyboard/mouse receiver dongle thingy.

Andy


I have the same result here, relative to the mouse scrolling. It doesn't seem to scroll in a command window or textbox. All of my wired and USB wireless mice work now. Some are Logitech, and some are Microsoft mice. BTW: my machine has the Nvidia video card, same as yours.

I decided to use Visopsys to view a fresh batch of dog photos. I have a #106 Lab/Rottweiler/GermanShepherd/SiberianHushy mix (We did the DNA swab to get that info, LOL).

Anyway, I added an extra partition to the USB stick I'm using for Visopsys, and I made that partition a lot bigger than the boot partition (1.5G), so that it could hold the photos. Then I loaded "Hutch's" photos from another machine onto the stick. Visopsys mounted the new photo partition with this command:

Code:
mount sd0b photos-partition


I discovered that the "mount" command creates the mount point automatically if it doesn't already exist. Wish my other OS's would do that! Using the file browser from image-edit, I could view the photo icons in the new partition OK, but after clicking on them, they seemed to be taking a long while to load. I decided that the photos might load faster from a ram disk, so I tried to make one with this command:

Code:
ramdisk create 100M 


That command didn't seem to work, though. I'll post a report about it in the bug-thread.

- Ron


Top
 Profile  
 
 Post subject: Re: Visopsys 0.81 Released
PostPosted: Mon Oct 02, 2017 12:18 am 
Offline

Joined: Mon Jan 23, 2017 6:57 am
Posts: 3
Congratulations on the 0.81 release! It now works on more machines than before! :D

**Visopsys 0.81 (CD) DOES boot on a early AMD64 machine with both IDE and SATA drives when id didn't before**
This is new!
I am now able to boot to the desktop using the IDE DVD drive.
Visopsys still fails to boot the SATA DVD drive, even with the IDE drives disconnected. It says "command failed - timeout" on identifying SATA devices.
Several factors which could confuse Visopsys on this machine:
1. The motherboard SATA controller I was using might not be 100% to spec. Debian Linux outputs periodic kernel errors about it to tty0 which do not affect the ability to read from drives on it.
2. There is additionally a PCIe IDE/SATA controller present.
3. A USB multi-card reader is present.

**Visopsys 0.81 (CD) does not???? boot on a Toshiba Satellite L305-S5919**
On the Satellite, there are still plenty of errors (about the USB card reader, I think); however, instead of displaying nothing but a mouse cursor it displayed: "Please enter your login name:" with a text field, and "Reboot" and "Shut down" buttons.
This was a bit odd, since no login was required for the live CD on the other machine, and I have no idea what username and password it wants.
I hit the "Reboot" button, and the second time and third times up it said it couldn't find the boot CD.
It also booted directly to an error on the fourth boot after I had physically powered off.

**Visopsys 0.8 (CD) does NOT boot on random Gateway Pentium 4**
It gets an "invalid command" error at the ATAPI command stage trying to identify and read the boot CD.

Let me know if you'd like any further testing or specs on these machines...


Top
 Profile  
 
 Post subject: Re: Visopsys 0.81 Released
PostPosted: Mon Oct 02, 2017 12:44 am 
Offline

Joined: Mon Jan 23, 2017 6:57 am
Posts: 3
I should note, however, that Visopsys still can't install itself on the computer it's newly able to boot on.
It reports "no drives registered", when there are in fact three:
1. An IDE drive attached to the motherboard controller.
2. A SATA drive attached to the motherboard controller
3. A SATA drive attached to a PCIe IDE+SATA+eSATA controller.


Top
 Profile  
 
 Post subject: Re: Visopsys 0.81 Released
PostPosted: Wed Nov 15, 2017 2:19 pm 
Offline

Joined: Mon Nov 13, 2017 9:32 am
Posts: 1
Uityyy wrote:
I should note, however, that Visopsys still can't install itself on the computer it's newly able to boot on.
It reports "no drives registered", when there are in fact three:


I just got that error too, did you get it installed?


Top
 Profile  
 
 Post subject: Re: Visopsys 0.81 Released
PostPosted: Thu Nov 16, 2017 10:12 am 
Offline
User avatar

Joined: Tue Nov 16, 2010 7:20 pm
Posts: 460
If you can boot from a stick or ISO, it would be useful to see what the 'Devices' (in 'Administration') program thinks about the hardware - disk controllers, disks, etc. Also, if you can boot from something writable like a stick, the kernel.log file in the /system folder might help us see what's going on. In theory, SATA/AHCI should be working.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 8 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group