Search found 22 matches

by oscar
Mon Sep 09, 2013 11:42 am
Forum: General
Topic: problem with imgboot trying to boot for the first time
Replies: 23
Views: 39009

Re: problem with imgboot trying to boot for the first time

Hi Andy,

Yes, I will try it now and I tell you what happens :)
by oscar
Fri Sep 06, 2013 5:26 pm
Forum: General
Topic: problem with imgboot trying to boot for the first time
Replies: 23
Views: 39009

Re: problem with imgboot trying to boot for the first time

Hello Andy, I didn't tried to compile with your version of gcc and binutils, I want to do it soon. But I tried to use two Visopsys iso images that I compiled with VirtualBox in another laptop that works with Windows. One iso was compiled from an unmodified source code, while the other iso was compil...
by oscar
Tue Sep 03, 2013 10:35 am
Forum: General
Topic: problem with imgboot trying to boot for the first time
Replies: 23
Views: 39009

Re: problem with imgboot trying to boot for the first time

Hi Andy, I think you're right and probably it's something related to the software version in my linux. I know that upgrading linux usually takes a lot of time (I'm also lazy upgrading to fedora 19 :lol: ), so I will try to use the same gcc and binutils that you have, and if possible I will use the s...
by oscar
Tue Sep 03, 2013 6:14 am
Forum: General
Topic: problem with imgboot trying to boot for the first time
Replies: 23
Views: 39009

Re: problem with imgboot trying to boot for the first time

Hi Andy,

What version of Linux are you using? I want to try to use the same Linux and software versions as you to see if it works or not.
Have a nice day!

Oscar
by oscar
Mon Sep 02, 2013 6:38 pm
Forum: General
Topic: Calculator for Visopsys
Replies: 7
Views: 15623

Re: Calculator for Visopsys

Welcome to the forum nextvolume :dance: It's fantastic to have a calculator program for Visopsys, in graphic mode and very complete. I was trying to port one that I have done for linux but I was having some problem to port it, and moreover mine is very simple as I'm still learning :geek: So thank yo...
by oscar
Fri Aug 30, 2013 2:53 pm
Forum: General
Topic: problem with imgboot trying to boot for the first time
Replies: 23
Views: 39009

Re: problem with imgboot trying to boot for the first time

Let's see :) 1. Yes, I installed the ISO image from your website (built in your sistem) and it runs perfectly in VirtualBox. 2. No, you're right. I can compile it successfully (at least the compiler says that) and put it in an ISO image. But when I try to run it, that error appears. 3. That is an in...
by oscar
Fri Aug 30, 2013 12:20 pm
Forum: General
Topic: problem with imgboot trying to boot for the first time
Replies: 23
Views: 39009

Re: problem with imgboot trying to boot for the first time

Hi Andy, Could it be something related to the hardware of my computer? If I have the chance, I will try to boot the same image in another laptop to see if I have the same problem again or not. By the way, you are telling me that you compiled Visopsys and after that you replaced its imgboot for the i...
by oscar
Wed Aug 28, 2013 2:29 pm
Forum: General
Topic: problem with imgboot trying to boot for the first time
Replies: 23
Views: 39009

Re: problem with imgboot trying to boot for the first time

Hello Andy, I think that the readelf of my previous post is from the source code plus two little programs that I tried to port. By the way, I'm glad to say that they worked in the Visopsys 0.72 that I installed in VirtualBox from the ISO image of the website, so I can try to write a more serious pro...
by oscar
Tue Aug 27, 2013 6:38 pm
Forum: General
Topic: problem with imgboot trying to boot for the first time
Replies: 23
Views: 39009

Re: problem with imgboot trying to boot for the first time

Hi Andy, I use Fedora Linux 18, recently updated, so I have the GCC version 4.7.2-8 and the binutils version 2.23.51.0.1-10. I used the command readelf and I attached its output here. I hope it helps you ;) Have a good night! :) $ readelf -e build/programs/imgboot ELF Header: Magic: 7f 45 4c 46 01 0...
by oscar
Tue Aug 27, 2013 1:29 pm
Forum: General
Topic: problem with imgboot trying to boot for the first time
Replies: 23
Views: 39009

problem with imgboot trying to boot for the first time

Hello Andy and Visopsys community, I tried to compile the Visopsys 0.72, and just after the Visopsys logo a pagefault error related to imgboot appears. It's always the same error. I tried to use the utils folder of the Visopsys 0.71 to see if the problem is related to the utils folder of the new ver...