visopsys.org

Visopsys Forums
It is currently Tue Apr 24, 2018 1:50 pm

All times are UTC




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: I desperately want to compile 0.72
PostPosted: Sun Oct 20, 2013 2:01 am 
Offline
User avatar

Joined: Sat Jan 15, 2011 8:06 pm
Posts: 36
Hi Andy!

I am so so happy you got your forum fixed. I love developing Visopsys because it's not too complicated for an operating system novice like myself but it can be expanded easily. Basically it's no MikeOS.

I've talked to you before via email about issues building and running 0.71 on my x64 bit Ubuntu system, you sent me the 0.72 source, and I still couldn't build and run (although I got farther than before.)

The problem happens during kernel init. It gets through most of it but then it panics.

Code:
Detecting hardware: PS/2 mouse Error::kernelPs2MouseDriver.c:waitForInterrupt(185):
No interrupt -- timeout
Error:kernel process:kernelDisk.c:identifyBootCd(1868):
The boot CD could not be identified
...
Disk functions initialization failed
...to reboot.


I'm trying this in qemu. When try your ISO, it works, so it's not the emulator. I edited all of the make files to compile, link, and assemble using 32 bits. The compilation runs without error and the ISO creates correctly. I feel like one of the problems may be how the ISO is being created. I'm running Ubuntu 13.04... about to run 13.10!

I'd really appreciate the help. I want to work on some gui styling and try to spice up the multitasker (long shot, I know. That's why I'm starting with the gui ;) ).

Thank you so much!

~osmiumusa :mrgreen:

_________________
Lemons. :) Nobody doesn't like lemons!


Top
 Profile  
 
 Post subject: Re: I desperately want to compile 0.72
PostPosted: Sun Oct 20, 2013 11:24 pm 
Offline
User avatar

Joined: Tue Nov 16, 2010 7:20 pm
Posts: 463
Hi mate, welcome back! And thanks for the kind words.

First of all, I suspect that the PS2 mouse driver may in fact be causing your boot failure, as suggested by the first error message.

I can reproduce this failure in VMware by wiggling the mouse during detection (it's a known issue, in other words).

Missing that mouse interrupt means that the disk interrupt doesn't get handled, so the boot fails.

Perhaps first try putting a return(0) at the beginning of the detection function in the PS2 mouse driver, and see if the boot seems to succeed after that. If so, then I can make solving the issue a higher priority. The PS2 mouse driver has always been a bit troublesome.

Andy


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group