visopsys.org

Visopsys Forums
It is currently Tue Apr 24, 2018 5:24 pm

All times are UTC




Post new topic Reply to topic  [ 25 posts ]  Go to page 1, 2, 3  Next
Author Message
 Post subject: Booting issue
PostPosted: Sat Jan 15, 2011 11:28 pm 
Offline
User avatar

Joined: Sat Jan 15, 2011 8:06 pm
Posts: 36
Hello,

When I try to boot my visopsys edit up, it crashes. It says it cant find the the cursor bitmaps. All I did was change the colors in kernelWindowTitleBar.c. However, I am not using your cd image script. For some reason, it returns an error. The error is at the bottom. So im using MagicISO, opening your iso file and replacing the VISOPSYS file with my slightly bigger VISOPSYS file that did "make" sucsessully. Any ideas?

Thanks. :mrgreen:

image-cd.sh error...

Making Visopsys CD-ROM IMAGE file
[: 30: ==: unexpected operator
- doing INTERIM Version 2011-01-15 (use -r flag for RELASES)

Making/copying boot floppy image... ./image-cd.sh: 46: Syntax error: Bad fd number

Must i have a physical cd in my drive? Must i make the floppy image first? The floppy script does not work either.

Using Ubuntu 10.04.1 in a VirtualBox on a Windows Vista 32-bit host.

_________________
Lemons. :) Nobody doesn't like lemons!


Top
 Profile  
 
 Post subject: Re: Booting issue
PostPosted: Tue Jan 18, 2011 5:27 pm 
Offline
User avatar

Joined: Tue Nov 16, 2010 7:20 pm
Posts: 463
Hi osmiumusa

What version of the Visopsys source are you using there?

I'm curious about what's going on with the image-cd.sh and image-floppy.sh scripts (I'm not familiar with MagicISO or how it does things, but it sounds like it might be screwing up the filesystem organization a little bit).

I'm assuming you haven't modified the scripts, but in any case can you post the relevant bits of your image-floppy.sh (line 30 and a couple of lines of context from above and below) and image-cd.sh (line 46 and some context).

Andy


Top
 Profile  
 
 Post subject: Re: Booting issue
PostPosted: Wed Jan 19, 2011 12:40 am 
Offline
User avatar

Joined: Sat Jan 15, 2011 8:06 pm
Posts: 36
I'm using the pre-release version: 0.70

I have only modified kernelWindowTitlebar.c
No other files have been edited. I think you may be right about the MagicISO problem. btw, what filesystem does visopsys use? It looks like, by the source files, that the kernel can do the popular ones.

Thank you so much for your help. :)

Osmiumusa

_________________
Lemons. :) Nobody doesn't like lemons!


Top
 Profile  
 
 Post subject: Re: Booting issue
PostPosted: Wed Jan 19, 2011 1:31 am 
Offline
User avatar

Joined: Tue Nov 16, 2010 7:20 pm
Posts: 463
Could you possibly insert the following line before line 46 in image-cd.sh?:
Code:
echo $RELFLAG $ISOBOOT $IMAGEFLOPPYLOG

and could you insert the following line before line 30 in image-floppy.sh?:
Code:
echo $1

and run image-cd.sh again?

When running from the CD, the filesystem is ISO, or UDF if it's a DVD.

On a hard disk or floppy, the filesystem is FAT (FAT12, FAT16, or FAT32 depending on the volume size).


Top
 Profile  
 
 Post subject: Re: Booting issue
PostPosted: Thu Jan 20, 2011 12:44 am 
Offline
User avatar

Joined: Sat Jan 15, 2011 8:06 pm
Posts: 36
Wow. Looks like you've got spam! Oh well...

Here is the new output of install-cd.sh

Making Visopsys CD-ROM IMAGE file
[: 30: unexpected operator
- doing INTERIM version 2011-01-19 (use -r flag for RELEASES)

Making/copying boot floppy image... -isoboot ./image-floppy.log
./image-cd.sh: 47: Syntax error: Bad fd number


It says bad fd number. For a virtual image like this one shouldn't there be no required fd number?

~Osmiumusa :mrgreen:

_________________
Lemons. :) Nobody doesn't like lemons!


Top
 Profile  
 
 Post subject: Re: Booting issue
PostPosted: Thu Jan 20, 2011 12:47 am 
Offline
Site Admin

Joined: Mon Sep 13, 2010 1:19 am
Posts: 5
Yeah, I'm fighting the spambots at the moment.

Does it create an image-floppy.log file? If so, what's in there?


Top
 Profile  
 
 Post subject: Re: Booting issue
PostPosted: Thu Jan 20, 2011 1:33 am 
Offline
User avatar

Joined: Sat Jan 15, 2011 8:06 pm
Posts: 36
Well, It doesn't even create the file. Then I created an empty image-floppy.log file and the script left it untouched. :/
I don't know whats up... what other suggestions?
It puts out a "visopsys-.img" but when I try to boot it, it says "This is not a visopsys boot disk, press any key to restart" or something of the like.

~osmiumusa :mrgreen:

_________________
Lemons. :) Nobody doesn't like lemons!


Top
 Profile  
 
 Post subject: Re: Booting issue
PostPosted: Thu Jan 20, 2011 1:54 am 
Offline
User avatar

Joined: Tue Nov 16, 2010 7:20 pm
Posts: 463
That is bizarre. It almost looks like the 'date' command isn't working the way the script expects.

Can you try running with the -r option? Like: ./image-cd.sh -r

Also, could you try adding 'set -x' to the beginning of both scripts, and posting the output? That should show us exactly what's happening.


Top
 Profile  
 
 Post subject: Re: Booting issue
PostPosted: Thu Jan 20, 2011 2:04 am 
Offline
User avatar

Joined: Sat Jan 15, 2011 8:06 pm
Posts: 36
-r does nothing special. I put the set -x at the begining of both scripts and this is what was spit out...


+ IMAGEFLOPPYLOG=./image-floppy.log
+ MKISOFSLOG=./mkisofs.log
+ ZIPLOG=./zip.log
+ echo

+ echo Making Visopsys CD-ROM IMAGE file
Making Visopsys CD-ROM IMAGE file
+ [ == -r ]
[: 1: unexpected operator
+ date +%Y-%m-%d
+ RELEASE=2011-01-19
+ echo - doing INTERIM version 2011-01-19 (use -r flag for RELEASES)
- doing INTERIM version 2011-01-19 (use -r flag for RELEASES)
+ echo

+ BUILDDIR=../build
+ ISOBOOT=-isoboot
+ NAME=visopsys-2011-01-19
+ FLOPPYZIP=visopsys-2011-01-19-isoboot-img.zip
+ FLOPPYIMAGE=visopsys-2011-01-19-isoboot.img
+ ISOIMAGE=visopsys-2011-01-19.iso
+ ZIPFILE=visopsys-2011-01-19-iso.zip
+ TMPDIR=/tmp/iso11104.tmp
+ rm -Rf /tmp/iso11104.tmp
+ mkdir -p /tmp/iso11104.tmp
+ echo -n Making/copying boot floppy image...
Making/copying boot floppy image... + echo -isoboot ./image-floppy.log
-isoboot ./image-floppy.log
./image-cd.sh: 49: Syntax error: Bad fd number


Thank you for all of the help

~osmiumusa :mrgreen:

_________________
Lemons. :) Nobody doesn't like lemons!


Top
 Profile  
 
 Post subject: Re: Booting issue
PostPosted: Thu Jan 20, 2011 2:18 am 
Offline
User avatar

Joined: Tue Nov 16, 2010 7:20 pm
Posts: 463
Thanks for helping me sort this out.

OK, I'm a little bit stumped. Can you post your image-cd.sh script? I know what the released one looks like, but I just want to make sure I'm looking at the same script as you've got there...


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 25 posts ]  Go to page 1, 2, 3  Next

All times are UTC


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group