visopsys.org
https://visopsys.org/forums/

Couldn't get past initial screen, keyboard/mouse not working
https://visopsys.org/forums/viewtopic.php?f=4&t=148
Page 1 of 2

Author:  maccool [ Thu Aug 25, 2011 1:01 pm ]
Post subject:  Couldn't get past initial screen, keyboard/mouse not working

Subject about covers it.

I have an old Dell Optiplex 330 that I was using as a way to segregate a drive I wanted to manipulate. I got Partitionlogic to boot to the first screen, but I could not select the OK as the mouse and keyboard weren't active.

Moved on to try my own variation of Gparted Live (added a couple of extra tools to use). That booted to the disk device list with working mouse and keyboard.

Good luck. I'll be looking for replies if you want more info.

Mac

Edit was to change could to couldn't in the subject line. Oops.

Author:  andymc [ Thu Aug 25, 2011 1:33 pm ]
Post subject:  Re: Couldn't get past initial screen, keyboard/mouse not wor

Hi Mac,

Thanks for the info. Can you tell me whether your keyboard and mouse are attached via PS/2 or USB?

Andy

Author:  maccool [ Thu Aug 25, 2011 1:54 pm ]
Post subject:  Re: Couldn't get past initial screen, keyboard/mouse not wor

You know, about 10 minutes ago I realized that I hadn't put that in there. At least not directly.

This version of the Optiplex 330 has no PS/2 ports at all. Mouse and keyboard are USB.

Author:  andymc [ Thu Aug 25, 2011 2:01 pm ]
Post subject:  Re: Couldn't get past initial screen, keyboard/mouse not wor

No worries, thanks for replying.

Yes, USB support has been a bit spotty so far.

However, I've been working on it pretty intensively over the last couple of weeks. If I were to provide you with a version built from my latest sources, would it be possible for you to re-test?

Andy

Author:  maccool [ Thu Aug 25, 2011 2:05 pm ]
Post subject:  Re: Couldn't get past initial screen, keyboard/mouse not wor

Sure, let me know where to get the iso and any other details and I'll have at it.

Author:  andymc [ Fri Aug 26, 2011 1:35 am ]
Post subject:  Re: Couldn't get past initial screen, keyboard/mouse not wor

Hi Mac,

Here's a link to my latest development ISO:
http://visopsys.org/files/misc/partlogic-2011-08-26-iso.zip

No special instructions; hopefully it will "just work" ;)

I've made quite a few important changes to the way USB controllers, hubs, and devices are handled, so I'm very interested to know whether you have better results with this one.

Andy

Author:  maccool [ Fri Aug 26, 2011 11:54 am ]
Post subject:  Re: Couldn't get past initial screen, keyboard/mouse not wor

OK, Andy, here's everything on the screen. Forgive any typos:

Visopsys 0.7
Copyright (C) 1998-2011 J. Andrew McLaughlin
Starting, one moment please...

Detecting hardware: USB bus controller Error::kernelUsbUnciDriver.c:doDSetectDevices(1708):
Error enumerating new USB device
Detecting hardware: ACPI power management Error::kernelMultitasker.c:exceptionHandler(938):
The kernel has experienced a page fault exception at application address 00000000


Then there is an outlined box in the center of the screen:

SYSTEM HALTED: Panic at KernelMultitasker.c:kernelException(1912)
Double-fault (page fault) while processing a page fault exception

Author:  andymc [ Fri Aug 26, 2011 12:39 pm ]
Post subject:  Re: Couldn't get past initial screen, keyboard/mouse not wor

Ah, bummer, looks as if the new power management code has an oopsie in it :doh:

That USB error may or may not be from the keyboard or mouse, so I guess I can't tell from this whether your original problem has been solved.

Thanks again for the help. If I can find that ACPI bug and have confidence that I've solved it, I'll post another link to a fixed version.

Cheers!
Andy

Author:  maccool [ Fri Aug 26, 2011 1:08 pm ]
Post subject:  Re: Couldn't get past initial screen, keyboard/mouse not wor

I'm game, just let me know.

Author:  andymc [ Sat Aug 27, 2011 1:40 pm ]
Post subject:  Re: Couldn't get past initial screen, keyboard/mouse not wor

I don't see any obvious problems with the ACPI code, so I'm working my way through my collection of test hardware trying to reproduce that crash. :think: If I can't, I'll post a version with that disabled so we can (hopefully!) find out whether I've solved the USB issues with your mouse and keyboard. :handgestures-thumbup:

Page 1 of 2 All times are UTC
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/