Stuck on detecting
Page 1 of 1

Author:  Dissident [ Fri Sep 16, 2011 8:56 pm ]
Post subject:  Stuck on detecting

Hello Visopsys Members

I am attempting to use the "Partition Logic" program in an attempt to create a partition, I've burnt it to a CD and booted it, I then receive a blue screen with a loading bar, then a detecting status, it detects around two to three pieces of hardware before getting stuck on "Detecting hardware: IDE disk Controller". I've left it there for around one hour yet there hasn't been any change. Am I expected to wait longer or is there a clear issue here?


Author:  andymc [ Fri Sep 16, 2011 10:58 pm ]
Post subject:  Re: Stuck on detecting

Hi Dissident,

Sorry you're having trouble with it. No, it shouldn't take more than a few seconds to do all of the hardware detection.

I assume you're using version 0.7, is that correct?

Do you know whether your system has SATA disks? Could you possibly go into your BIOS setup and see whether the SATA controller is running in AHCI/native mode or IDE/legacy mode?


Author:  Dissident [ Sat Sep 17, 2011 1:24 pm ]
Post subject:  Re: Stuck on detecting

I am currently running on version 0.7 and on a HP Compaq nc4400 laptop.

I'm pretty sure the system has SATA disks and how would I access the BIOS setup? Sorry but I'm quite new to all this :D

Edit: Ah, I've just saw an option here saying "SATA Native Mode - Enabled

Edit #2: Just disabled SATA Native Mode and is now goes past the IDE Disk Controller, yet the next item to come up is PS/2 Mouse and it sort of crashes, I get an error message stating:

Error:kernel process:kernelFilesystem.c:kernelFilesystemMount(617)
No such disk "cd0"
Error:kernel process:kernelInitialize.c:kernelInitialize(395)
Mounting root filesystem failed
Error:kernel process:kernelMain.c:kernelMain(77)
Initialization failed. Press any key (or the "reset" button) to reboot.

I assume that disabling the SATA Native Mode was a bad idea?


Author:  andymc [ Sat Sep 17, 2011 1:37 pm ]
Post subject:  Re: Stuck on detecting

I think you found the setting :clap: :lol: That's in the BIOS setup, yes?

Native SATA isn't really supported yet (that's being worked on). Can you try changing that setting to "legacy" or "IDE" or "ATA"? (they all mean the same thing in this context)

Author:  Dissident [ Sat Sep 17, 2011 1:55 pm ]
Post subject:  Re: Stuck on detecting

I can't change it to those I'm afraid, it's just Enable or Disable, and I'm not entirely sure I'm in the right menu, I press f10 and it says "Rom Based Setup", then I get a menu with tabs "File, Security, Diagnostics, System Configuration" I go to the System Configuration tab and go to Device Configurations settings, I have a list of settings I can change. I'm using a plug on device with a CD drive due to the laptop not having one, would that be an issue?

Author:  andymc [ Sat Sep 17, 2011 3:50 pm ]
Post subject:  Re: Stuck on detecting

Can you change the "SATA native mode" to disabled?

The plugged-in CD drive might not be detected by the 0.7 version that you have, but the upcoming 0.71 version might be able to handle it (is it USB? I've never tried a USB CD with this system)

Author:  chillwill96 [ Sat Sep 29, 2012 2:13 am ]
Post subject:  Re: Stuck on detecting


Im trying to restore my old SONY VAIO desktop and in the process trying to join together drive C: to a partition that someone made thats making things difficult. anyway. I already deleted the logical drive partition and put in the Partition Logic cd and its stopping at Detecting hardware: IDE disk controller..


Author:  andymc [ Sat Sep 29, 2012 11:17 am ]
Post subject:  Re: Stuck on detecting


Which partition do you mean by the "logical drive partition"? Was it something like the D: drive in Windows?

What software did you use to delete it? Did you use Partition Logic for that? (i.e. did it load successfully on a previous attempt?)


Page 1 of 1 All times are UTC
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group